Changelog

ecoDMS Version 16.09 (eleanor)

ecoDMS is now also available for Ubuntu 18.04 LTS. You can find the necessary apt source in the installation manual.

Updating

We value the security of your data and information. With each update we optimise our software. We also take into account the latest security standards. We therefore recommend you always install the latest version of all ecoDMS components. You must backup your system before each update and follow the installation steps from the installation manual.

Security Information

We value the security of your data and information. With each update we optimise our software. In doing so, we work according to the latest security standards. We therefore advise you to always install the latest version of all ecoDMS components.
perm_phone_msg
arrow_upward