images/mainpages/company/system-requirements-system-voraussetzungen-ecodms.jpgThe client-server system can be installed on multiple computing platforms under different operating systems.
Read the system requirements of ecoDMS Version 18.09 (apu) here.
Read the system requirements of ecoDMS Version 16.09 (eleanor) here.
Read the system requirements of ecoDMS Version 14.08 (krusty) here.
Read the system requirements of ecoDMS Version 12.05 (brandine) here.