Read the technical requirements for the ecoDMS Mobile App on Android devices here.
Android 2.3.3 & higher ca. 70k Connecting to the Internet from your mobile device is required.
The ecoDMS Server must be accessible online.

Direct Manufacturer Support

Our support team will be pleased to address your technical and content-related questions regarding ecoDMS GmbH software.