Changelog

ecoMAILZ: Automatic Email Archiving

The update for the ecoMAILZ email archive has been released with build 1.0.8. The update includes the following new features, bug fixes and improvements:

System Requirements
  • From ecoMAILZ 1.0.8 and later, ecoMAILZ also runs under Debian 11 (bullseye) and Windows 11
  • Debian 9 (stretch) is no longer supported from ecoMAILZ version 1.0.8 and later
New Features
  • Exports all archived emails as .eml file
  • Retention periods for emails with manual and automatic erasure
  • Transfers journal emails using the file system adapter
  • New adapter for Microsoft 365: Connection via current Graph API
  • Erasure logs can be switched on/off with a new user permission
  • Configurable automatic deletion of erasure logs
Bugfixes
  • Exchange adapter: Displays emails with public groups
  • Fixed behaviour of emails with empty date
  • Fixed restoration process of a backup for specific containers
  • Adjusted license deactivation on restart of NAS
  • POP3: SSL/TLS revision of email retrieval
  • Revised full-text search with AND and OR
  • Journal emails: Fixed errors in the adapter for certain emails
Improvements
  • Improved incremental backup and restore
  • Automatic logout on inactivity
  • Displays a loading icon while searching
  • Displays a load dialogue for backup / restore
  • Switch to Java 11 + TLS1.3
  • Adapters cannot be deleted if users are included in them
  • Mail details: Icons for Download and Download PDF
  • Folder selection dialogues: Display of the entire folder name

Installation Information for ecoMAILZ 1.0.8:

  • Always read the notes and steps in the installation manual.
  • Before updating / upgrading, you must create a full and clean backup.
  • Always read the system requirements before installing the programme. Make sure that your system environment complies with the ecoMAILZ requirements.

Security Information

We value the security of your data and information. With each update we optimise our software. In doing so, we work according to the latest security standards. We therefore advise you to always install the latest version of all ecoDMS components.