Read the technical requirements for the ecoMAILZ plugin for ecoDMS here.
Windows 10
Windows Server 2012 R2, 2016
Ubuntu LTS 16.04, 18.04
Debian stretch
64-bit (ecoMAILZ supports modern 64-bit systems) ecoDMS Version 16.09 (eleanor) build 16.09-2 or later & ecoDMS PDF/A Printer version 16.09 (eleanor) build 16.09-2 or later The read aloud function is not available in the plugin.

System Environment

Please note the official system requirements for each application before installation. If your system does not meet these requirements, we cannot guarantee the smooth and stable operation of our software.

Direct Manufacturer Support

We are pleased to offer professional support and services on the way to digitalising and archiving your documents.