• When updating, always refer to the notes on our website / in the change log.
  • ALL ecoDMS components (server, clients, plugins) must be updated. As version 14.08 (since update-9) now encrypts communication as a default, older clients can no longer access the server.
  • After you have updated all components, you should restart the ecoDMS server service on the server and the connection manager of the clients.