ecomailzRead more about the system requirements for the individual software versions of "ecoMAILZ".
Read the system requirements of the current ecoMAILZ Version 17.08 (donnie) here.